wordpress更新でエラー。PHP更新で復帰

ダッシュボードから、いつもの更新作業を実施。
image

「今すぐ更新してください」をクリックしたら、すぐにエラー
image

Perse error:snyntax error,unexpected T_FUNCTION…….
-populer-post-controller on line324.

なんだこれ。 見たことないエラー
ちょっとどきどきします。 最悪ブログが消える。 しかもバックアップしていない。
プラグインを削除すればよいかな?
ネットで類似例を検索。

WordPressアップデート後管理ページにアクセスできなくなりました。
https://teratail.com/questions/47604

これが参考になりそう。ロリポップのphpバージョンを上げてみよう。

https://lolipop.jp/manual/user/php-setting/#p-php-version

image

ユーザーページから
サーバの管理・設定→PHP設定

image

PHPのバージョンを見ると、5.2(CGI版)となっている。
新しいバージョンとして、5.6と7.1が選べる。
ここは7.1にアップしてみよう。

image

7.1→変更 →設定
設定変更には数分かかるようだ。

image

3分くらいかな? たって、F5更新してみたらダッシュボードがエラーから復帰。
ふー よかった。

image

とりあえず更新の前に、コンテンツをエクスポート(export)しておこう。

image

XMLドキュメントで521KBある。 前回からの差分の復旧は不可能な状態でした。
あぶなかったー

その後何事もなくwordpressの更新完了です。





コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA